G Scale Model Train Forum banner

1 - 17 of 17 Posts

·
Premium Member
Joined
·
2,910 Posts
Discussion Starter #1
Apparently it is arriving at retailers--RLD hobbies, one of my favorite dealers, says they have it in stock

I saw an early production model at the ECLSTS, and I was not that impressed--the engine shell was well done, but the running gear, as I remember somebody else here saying, was very toy-like. I think I remember a thread where someone said they had improved it for the final production run. Has anyone seen it?
 

·
Premium Member
Joined
·
1,976 Posts
Mike,

The ones I saw were preproduction. The shell was nice, but the running gear was chinsy. Plastic chrome plated side rods. I don't plan on being the first to own one of these.

Mark
 
G

·
Guest
Joined
·
0 Posts
Mike, Mark,
Ive got 2 comin should be here today or tommarrow i will take pictures and post them as soon as the engines arrive. i was told lower end of loco was updated no plastic....
Nick..
 

·
Premium Member
Joined
·
4,297 Posts
And neither the manufacturer or the sellers have any new pics yet? Odd..if its been significantly changed.
 

·
Registered
Joined
·
38 Posts
Got one today. Side rods are metal. Sound trigger for bell and whistle are in the main body. Because of that they sent special magnets that sit rather high. Higher then what i have for other engines. Sound only comes on when engine starts to move. Sound is ok could be better. Blue light led for front and rear light. Over all nice peice. Heavy at 13 lbs. Lack of instructions. Standard what USA sends. Came with extra plug not yet figured what it is for as of this time. When I opened the the foam cover it said not to remove untill you read unpacking instructions. Did not get any. No problem to un-pack
Runs well did not test to see how many cars yet or test on grade.
Mike
 

·
Premium Member
Joined
·
217 Posts
Hi - They are at Charles Ro right now. I can take some photos this weekend and post them on Monday. I thought it was a handsome little engine.
 

·
Premium Member
Joined
·
639 Posts
Got mine today. Very smooth runner, starts at about 4 volts. Chuff sound not bad, but bell and whistle will make you glad the track magnets don't fit LGB track. However the sides of the magnet mount is easily trimmed to fit. The plug fits a socket on the PC board under the coal load for an easy battery connection, but there's no way to easily disconnect the track power that is obvious. Also, the couplers are at USAT height, so a change to KD's will be a must for me.
 

·
Premium Member
Joined
·
639 Posts
Okay, I'll take back what I said about the Bell and Whistle sounds. Makes a big difference if the coal load is in place, which completes the speaker enclosure. Actually, they sound pretty good.
 
G

·
Guest
Joined
·
0 Posts
/DesktopModules/NTForums/themes/mls/emoticons/w00t.gifPosted By vsmith on 09/13/2008 8:07 PM
no pictures???????????




Sit Tight, their uploading now...
Nick.../DesktopModules/NTForums/themes/mls/emoticons/shocked.gif
 
1 - 17 of 17 Posts
Top