G Scale Model Train Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
I'm wondering if the transformer I had the same problems as yours, haven't bought a new one yet and that one was on sale for I think $25

You wouldn't happen to have bought that transformer in Baldwinsville would you?


 
 

·
Registered
Joined
·
934 Posts
Nope. Got my LGB 50081 transformer off of EBAY. Gave better than fifty bucks for it what with the postage and all.

Like I said in the other thread, I was able to fix it - I pulled the knob off (it was the only thing I could get off, given the 'bomb-proof' casing), and almost immediately noticed that the 'shaft' the knob was attached to could rotate in a full circle. In short order, I came up with the idea that for some reason, the knob on this transformer had been 'set' incorrectly. I then tested it with the knob off, train ran full speed in both directions. I dunno...manufacturer defect? some prior owner messing around with it?
 

·
Premium Member
Joined
·
4,716 Posts
Told you there was something wrong with it/DesktopModules/NTForums/themes/mls/emoticons/laugh.gif
 

·
Registered
Joined
·
934 Posts
I may have spoken too soon about 'fixing' the dratted thing.

I got to playing with it a bit. I noticed that it seemed to have exactly two speed settings - 'full speed' and 'stop'; no slow speed, no gradual acceleration. A couple times the Annie took off in such a hurry it actually came uncoupled from the tender! (hook and loop deal). Never had that happen before. The smaller locos actually threw off sparks a time or two from the high speed takeoffs. Plus...well, the transformer has four speed settings, one through four. The locomotive wouldn't even move in either direction until it was on setting 2.5 - then bam! - full speed ahead.

I guess its usable...but its not really my first choice (though I'll no doubt mess around with it some more).

Get right down to it, I'm actually more impressed with those little silver Bachmann transformers. Anybody have any of those they want to send me?
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #5 ·
my bachman transformer - the silver one - won't barely move my usa trains sw-2 with 80' of track, forget about using the smoke unit, the bachmans run fine with it. I know it's not the usa train - i use that on the club layout once a week without any problems
you might want to just bite a bullet and get a larger transformer and be done with it
 

·
Registered
Joined
·
934 Posts
my bachman transformer - the silver one - won't barely move my usa trains sw-2 with 80' of track, forget about using the smoke unit, the bachmans run fine with it. I know it's not the usa train - i use that on the club layout once a week without any problems
you might want to just bite a bullet and get a larger transformer and be done with it


I've considered it more than once - especially after this last fiasco. Still, it'll have to wait given that I've spent almost all my train money for a few months...
 
1 - 6 of 6 Posts
Top