G Scale Model Train Forum banner

1 - 20 of 22 Posts

·
Premium Member
Joined
·
254 Posts
Discussion Starter #1
I look at the properties of a link in IE that always worked.



"ftp://bobgrosh%40gold.mylargescale.com:mypassword@1stclass.mylargescale.com"



On my XP and 98 systems this took me to my ftp web space where I could drag and drop files to and from my MLS space.

On my VISTA machine, it requires an extra step. I had to tell it to open it in explorer.

I also had another way to get to my space. It was a web folder available on the desktop and through a drive letter in windows explorer.



After the "sync" none of my computers can get into my web space. Web folder does not work, the links on all my PC's (2-98's, 1XP, 2-VISTA) don't work either.



mypassword has always been the same on both both the forum login and the ftp login. (I even used the same password got my deadhead and ALLY user names)

I tried the manual method of displaying my web space in IE:

I tried substituting 1stcalss for gold and tried substituting my hotmail email for mylargescale.com



None of it works

I can get to it through the http interface but manualy creating 10 subdirectories and manually copying 3000 files using the stupid browes buttons is a NO GO.



What do I have to do?


What do I have to do?
 

·
Premium Member
Joined
·
4,393 Posts
Bob

While I don't use any of the operating systems that you mention (I use Win2K Pro), however, when I performed the MLS SYNC procedure I encountered no problem with any of my FTP clients no longer working. The closest I come to what you are doing is the use of MS/Internet Explorer's (v6.0.2800 SP1) native FTP client and it still works as it always has.

The only thing that I see different between what I show in the address field as opposed to what you show, is that the '@' sign isn't translated to '%40' on my system, and since you're going into a UNIX based system I'm not sure that the '%40' will be an acceptable character string, don't know if that is it but it's what I see.
 

·
Premium Member
Joined
·
4,393 Posts
After looking at the FTP address a bit more and cross-checking what I've got set up in each of the FTP clients that I use (i.e. total of 3) none are set up to attempt logging in directly to my home directory (i.e. /stevec) instead they are set up to log on to the MLS FTP server (gold.mylargescale.com or 1stclass.mylargescale.com) and with the entry of my User ID and password I'm placed into my home directory.
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter #4
If I change %40 to @ then IE imediatly gives me a web site not found, check your spelling error.
If I use the line as I listed it, then I get a popup diaglog box asking me for a user name and password.
It has worked that way for years.
However, now entering the user name and password does not get me anywhere.
 

·
Premium Member
Joined
·
4,393 Posts
Yes I understand that its been working for years, however, now it doesn't. Have you tried logging in to the MLS FTP site without using any reference to your home directory (i.e. gold.mylargescale.com or 1stclass.mylargescale.com)? Then providing the User ID and password.

I know it may be a pain, but when I encounter problems with logging on to FTP sites, I'll fall back to using the command line version of the FTP client to work out the kinks, since the error messages provided are a lot more help than the GUI interface ever does, just a thought. :D
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter #6
yes.
I can get to the logon screen but it will not take my user name and password.
Well. I take that back.
It did let me in ONCE that way but kept giving me errors saying I did not have permission to see my files and folders. I could see the root directory but I got the error trying to open folders.

I only did that ONCE about 15 minutes ago.
 

·
Premium Member
Joined
·
1,767 Posts
Nothing in the synch changed the way the FTP server accepts connections. I only made it so that the FTP software was automatically notified of your username and password.

One thing I just noticed is that you're still using [email protected].. Change that to [email protected].. That may help. Any reference to 'gold' is going away soon, so you should make sure that you're not using that in any of your posts or any of the access you're using.


I just logged in to my space fine using your method.
 

·
Premium Member
Joined
·
5,510 Posts
I wonder... in the "Sync" process you were to make a change and then change it back... did you change it back? Did you possibly not change it back to what it actually was originally. It is possible that you cannot actually change it back to what it was if there was a space or some other hard to "see" character in the original that got removed, either by your retyping it or the system deciding it should not have been there (like a space, or some non-printable character that you didn't know was there to begin with). The space character is often a culpret in situations like this... it is possible that when the name was originally entered, two spaces got in and now-a-days lots of systems automatically reduce double spaces to single spaces and what seems to be minor changes become major problems, through nobody-in-particular's fault.
 

·
Registered
Joined
·
1,578 Posts
I wonder if the socket got changed?




I know, my bad.
 

·
Premium Member
Joined
·
5,510 Posts
Posted By Curmudgeon on 09/08/2008 10:46 AM
I wonder if the socket got changed?
I know, my bad.





You're bad? YOUR BAD?

With apoligies to Theodore Giesel...
-----------------------------------------
This was written in 1995 by Gene Ziegler.

Here's an easy game to play.
Here's an easy thing to say:

If a packet hits a pocket on a socket on a port,
And the bus is interrupted as a very last resort,
And the address of the memory makes your floppy disk abort,
Then the socket packet pocket has an error to report!

If your cursor finds a menu item followed by a dash,
And the double-clicking icon puts your window in the trash,
And your data is corrupted 'cause the index doesn't hash,
Then your situation's hopeless, and your system's gonna crash!

You can't say this?
What a shame sir!
We'll find you
Another game sir.

If the label on the cable on the table at your house,
Says the network is connected to the button on your mouse,
But your packets want to tunnel on another protocol,
That's repeatedly rejected by the printer down the hall,

And your screen is all distorted by the side effects of gauss
So your icons in the window are as wavy as a souse,
Then you may as well reboot and go out with a bang,
'Cause as sure as I'm a poet, the sucker's gonna hang!

When the copy of your floppy's getting sloppy on the disk,
And the microcode instructions cause unnecessary risc,
Then you have to flash your memory and you'll want to RAM your ROM.
Quickly turn off the computer and be sure to tell your mom!
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter #11



Trying to follow instuctions from FAQ




 




MLS â€" Internet Explorer FTP Connection




 




Open an Internet Explorer browser window.



In the Address bar text box type in: ftp://1stclass.mylargescale.com



Next either press the Enter key or click the Go button at right end of Address bar.



After the Login As dialog displays.



In the User Name: dropdown text box type in your MLS User ID. (Remember that even if there are space character(s) in your regular MLS User ID they are removed in your 1st Class Web Space ID, also remember that User ID entries are not case sensitive and are usually entered in all lower case.)





e.g. [email protected]





([email protected])

I USED [email protected]


In the Password: text box type in your regular MLS User Password. (Remember that password entries are case sensitive.)



Select the Save Password option. THERE IS NO SUCH CHECK BOX


Next click the Login button. Not one of these either, it is a "Log On" button.



There is a "log on anonymously" check box not mentioned here. I tried both ways, checked and not checked.



(After the "Login As" dialog clears and the browser window refreshes you will most likely see nothing in your MLS web space listed. Hold On! There’s nothing wrong. By default Internet Explorer is set up to Login using the "Anonymous" User ID and even though you typed in your MLS User ID and Password it tried using the "Anonymous" User ID. Look down in the lower right of the Internet Explorer’s window to the status line and you should see "User: Anonymous" listed. The MLS FTP Server isn’t configured to accept "Anonymous" User ID logins, and no I don’t know why there isn’t any error displayed. )



I get a page that says "Internet Explorer cannot display the webpage"

Using the Internet Explorer’s menu bar, Open the File menu. Highlight and click the Login As… option. There is no Login As under the file menu of this window so the rest is not posible..



After the "Login As" dialog displays. (Note, in the User Name: field your MLS web space User ID should already be listed by default (i.e. [email protected]), and there should be multiple asterisks entered in the Password: field representing your MLS web space access password.)



Click the Login button. (This time after the "Login As" dialog clears and the browser window refreshes you should see the contents of your MLS home directory listed.



 My short cut was so simple. click on it, then select "open in Windows Explorer". It worked on this machine a few weeks ago with "gold".

I have replaced "gold" with "1stclass" and that has not changed anything.
 

·
Premium Member
Joined
·
4,393 Posts
Bob

Edit Update: The only other thing that I can think of, and it doesn't make sense that it would get changed, but if you are using ADSL or a proxy you need to use Passive mode FTP, which is controlled by the Enable folder view for FTP located on the Advanced Tab of the Internet Options dialog in the Browsing section. You have to deselect the option to use passive mode FTP.

Have you tried using the DOS command line FTP and see if you can manually create a working connection that way?

I understand what you are saying, but you don't happen to mention which version of the MS/Operating System or the version of MS/Internet Explorer you are using while following the instructions.

The instructions that are included in the FAQ are representative of the steps that I followed using...[*]MS/Internet Explorer v6.0.2800.1106 SP1[*]MS/Windows 2000 Pro v5.00.2195 SP4[/list]I just went back and wiped out the MLS FTP connection that previously existed in MS/Internet Explorer and recreated it, and the steps listed in the FAQ are exactly what I followed, and I encountered no problem in recreating the FTP connection.

I also dug around and found the instructions on how to create a WebFolder/WebDAV folder and/or FTP connection in the 'My Network Places', using the 'Add Network Place Wizard' available in the 'My Network Places' or the 'Map Network Drive...' option available on the right-click context menu of either the 'My Computer' or 'My Network Places' icons on the Active Desktop.

I know that the version of the Microsoft software used in MS/XP & Vista is different than what I'm using in MS/Win2K Pro, so I don't have the faintest idea if the dialogs and prompts are the same. However, the only way that I could get the FTP connection to work for me was to...[*]Entered the following for the value in the location for the Network Place.[*]ftp://1stclass.mylargescale.com[/list][*]After clicking the Next button, and the User dialog displayed.[*]I unchecked the 'Log on anonymously' option.[*]Left the 'User name' field blank.[*]Clicked the Next button.[/list][*]After the 'Completing the Add Network Place Wizard' dialog displayed.[*]Accepted the default value for the name (ftp://1stclass.mylargescale.com).[*]Clicked the Finish button.[/list][*]I was returned to the My Network Places window, where the FTP connection was created.[*]Next, the system automatically opened an MS/Internet Explorer browser window for the MLS FTP connection, with the following value for the FTP address.[*]ftp://1stclass.mylargescale.com/[*]The area for display of folders & files was blank.[/list][*]At this point I...[*]Clicked the File menu on the browser's menu bar.[*]Selected & clicked the Ligin AS... option.[*]After the Login As dialog displayed...[*]Created the User Name: [email protected][*]Entered my password value.[*]Made sure the Login Anonymously option wasn't selected.[*]Made sure the Save Password option was selected[*]Clicked the Login button[/list][*]After the FTP Login process was completed, the folder/file area of the FTP browser window was populated with the information of my MLS web space.[*]The value displayed in the Browser's address field was...[*]ftp://[email protected]/[/list][*]The value displayed in the User: area in the Status Bar was...[*]User: [email protected][/list][/list]
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter #13
Thanks steve, I'm using VISTA right now and IE 7.0
The enable folder view for FTP located on the Advanced Tab of the Internet Options dialog in the Browsing section was checked. I have always had it checked for this to work. As per your instructions I unchecked it. That did not help at all so I went bac to checked.

Your discription seems correct for how i have my web folders set up.

As mentioned, these were working a week or so ago.

On this computer (VISTA) in windows explorer under Computer\1stclass.mylargescale.com I can see my MLS web space sub directories and files.

(Gosh That sounds promising)

I can click on folders and see sub folders. (getting better)
I can even copy a file from my hard drive to one of the sub folders with drag and drop.
However, I can no longer open any of the files, overwrite or delete them. When I attempt that I am asked to inter my user name and password and then I am told I do not have permission.

I went in the shop and found a computer that has not been fired up in months. It is a windows XP. It too had a web folder for my MLS web space. Same problem there.
 

·
Premium Member
Joined
·
4,393 Posts
Well, at least it seems you're making some progress you can Login & move files up to the server. I know without the over-right, open, & delete, big deal.

I went back and cross-checked and I've got full functionality on all of the new FTP connections that I created.

I know that in Vista and I believe XP too. You don't have access to an old style MS/DOS command line interface. So the following will most likely be of no use because you can't compare it to any thing, but just for the giggles & grins.

The following is the responce from the MLS FTP server when executing the "remotehelp" command...

FTP> remotehelp

214-The following commands are implemented     ABOR ACCT ALLO* APPE CDUP CWD DELE FEAT+ HELP     HOST+ LANG+ LIST MDTM+ MLST+ MKD MODE NLST NOOP     OPTS+ PASS PASV PORT PWD QUIT REIN REST RETR     RMD RNFR RNTO SITE SIZE SMNT STAT STOR STOU     STRU* SYST TYPE USER XCRC XCUP XCWD XMD5 XMKD     XPWD XRMD XSHA1     + = FTP extensions, * = accepted but not processed 214 HELP complete
 

·
Premium Member
Joined
·
4,393 Posts
I know this sounds nuts, but could it have something to do with the local permissions granted to the user that you're logging on to the local system with, and nothing to do with the actual FTP permissions at all.
 

·
Premium Member
Joined
·
5,510 Posts
In XP you get the old DOS command line interface by clicking on "Start, RUN..." and typing in "CMD" (without the quotes) and click 'OK'.
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter #17
finally
the web settings did have "gold" in them for the user name. IE [email protected] as a user nname
I changed gold to 1stclass and it still didn't work.

What confused me was, while the username [email protected] will get me in and I can see the files, I can't do anything with them

When I tried to delete or rename a file it would ask for my user name and password and then deny access.

Finally I just used "bobgrosh" as the user name and was able to do whatever with the file

So, I went back and removed the "@1stclass.mylargescale.com" part of the user names entirely. Now everthing works.

Something changed during the sync, just not sure what.


thanks

B0B
 

·
Premium Member
Joined
·
254 Posts
Discussion Starter #19
yea except it's not.

I can open the space in web folder.
I can drag files from to to my local drive. I cawatch the progress br it copies the files
I can drag files from my local drive to the web folder, and again see the progess bar.
The new files are now showing up in my web folder
When I use IE to look at my web space, the new files are not there. I still can't post links to the new files.
 
1 - 20 of 22 Posts
Top