G Scale Model Train Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
760 Posts
Discussion Starter #1
All,

I picked up an inexpensive LGB 2085D Mallet in need of some first aid. Having disassembled it and cleaned it up a bit, the front motor seems to be shot. Out of the motor block it runs slow, wobbles, gets hot, and runs erratically. Since this is quite an old loco, I'm not even going to try messing with the motor--I'll just order a replacement.

However, since this is used item, I don't have the manual and my online search for which motor this is has turned up different answers. I _think_ it's the long shaft motor, 62201. Could someone in the know confirm that?

Also, from another thread I saw it argued both ways (as I recall) about installing a pair of new motors to ensure they run the same. Anyone want to reopen the argument?

Thanks.
D
 

·
Premium Member
Joined
·
3,883 Posts
Measure the over all lwngth of the motor shaft and post the results.
I keep both the short and long shaft motors as spares.
Better yet, call in the length to trainli.com as they stock these motors and they indeed are the new type.
 

·
Registered
Joined
·
760 Posts
Discussion Starter #5

·
Registered
Joined
·
760 Posts
Discussion Starter #7 (Edited)
Apologies. Clearly have not had my morning coffee yet. Thought you said the front one...
No I apologize. I said front, but it's actually the rear :eek: I guess I'll have another cup myself :)

In my defense though, I was up until 2:00 fiddling around with the Mallet and sound buildings, and my two-year-old woke me up at 6:00
 
1 - 8 of 8 Posts
Top